给Windows 8更新Powershell

是这样,最近在纯之大佬的帮助下弄了Azure的Windows server 2012 r2的小鸡

打算挂探针上,结果探针的脚本要最低psl5才能运行,win8上刚好是3,r2上也只是4而已

要么手动安装(懒得动),要么就更新psl呗

https://download.microsoft.com/download/6/F/5/6F5FF66C-6775-42B0-86C4-47D41F2DA187/Win8.1AndW2K12R2-KB3191564-x64.msu

上面这个连接是psl5.1的更新包,虽然不知道为啥是个补丁包就是了

:qy_chigua:

反正又不影响使用,管他呢

实测2012 r2上确实能用

Tips:安装完成了需要重启

重启完了就可以执行以下这个指令来看当前的psl版本

PS C:\Users\你猜我用户名是啥> $PSVersionTable

Name                           Value
----                           -----
PSVersion                      5.1.14409.1005
PSEdition                      Desktop
PSCompatibleVersions           {1.0, 2.0, 3.0, 4.0...}
BuildVersion                   10.0.14409.1005
CLRVersion                     4.0.30319.42000
WSManStackVersion              3.0
PSRemotingProtocolVersion      2.3
SerializationVersion           1.1.0.1

可以看到是Powershell5.1了,探针直接正常安装了事

点赞

赞助商广告

如果您的网络和设备条件允许,这里可能会显示来自Google的广告

  1. 凡尘说道:
    Google Chrome Windows 10/11
    好久没来看了,教程还是很详细的
    1. 晓空说道:
      Google Chrome Windows 10/11
      :huaji13:

发表回复

电子邮件地址不会被公开。必填项已用 * 标注